Notes error: Could not open the ID file

Project:Awesync
Version:4.11.0
Component:ID/encoding
Category:support request
Priority:critical
Assigned:redona
Status:closed
Description

Hi,

I can't configure Awesync , he doesn't open the ID file.
My password is good.
 
Configuration: windows vista, lotus notes 7
 
Awesync logs:

2011-02-14 17:38:38,140 [1] INFO  - Essaie de déterminer les paramètres Notes ...
2011-02-14 17:38:38,146 [1] DEBUG - Récupération du registre : HKEY_LOCAL_MACHINE\SOFTWARE\Lotus\Notes
2011-02-14 17:38:38,149 [1] DEBUG - Récupération du registre isMultiUser : True
2011-02-14 17:38:38,152 [1] DEBUG - Récupération du registre : HKEY_LOCAL_MACHINE\SOFTWARE\Lotus\Notes\7.0
2011-02-14 17:38:38,155 [1] DEBUG - Récupération du registre isMultiUser : True
2011-02-14 17:38:38,157 [1] DEBUG - Branches de registre trouvées : 2
2011-02-14 17:38:38,160 [1] DEBUG - Branche : 99 / Chemin : C:\program files\notes\ / IsMulti : True
2011-02-14 17:38:38,163 [1] DEBUG - Branche : 7.0 / Chemin : C:\program files\notes / IsMulti : True
2011-02-14 17:38:38,166 [1] DEBUG - Finding "NotesIniPath" on: HKEY_CURRENT_USER\Software\Lotus\Notes\7.0
2011-02-14 17:38:38,169 [1] DEBUG - Recherche de Multi : C:\Users\J08157\AppData\Roaming\Notes\notes.ini
2011-02-14 17:38:44,767 [1] ERROR - Notes error: Could not open the ID file
2011-02-14 17:38:46,342 [1] DEBUG - System.Runtime.InteropServices.COMException (0x80040FA0): Notes error: Could not open the ID file
   à Domino6.NotesSessionClass.Initialize(String pPassword)
   à AweSyncLib.Domino.NotesSession.#=qOhFVob21xp82S80XriKT3w==()
   à AweSyncLib.Domino.NotesSession..ctor(Settings settingsParam)
   à AweSyncLib.LotusHelper.ConnectLotusNotes(Settings settings)
   à AweSync.WizardForm.ValidateLotusCredentials()
2011-02-14 17:38:51,671 [1] ERROR - Notes error: Could not open the ID file
2011-02-14 17:38:52,825 [1] DEBUG - System.Runtime.InteropServices.COMException (0x80040FA0): Notes error: Could not open the ID file
   à Domino6.NotesSessionClass.Initialize(String pPassword)
   à AweSyncLib.Domino.NotesSession.#=qOhFVob21xp82S80XriKT3w==()
   à AweSyncLib.Domino.NotesSession..ctor(Settings settingsParam)
   à AweSyncLib.LotusHelper.ConnectLotusNotes(Settings settings)
   à AweSync.WizardForm.ValidateLotusCredentials()


#1

Status:active» more info

Hi,
 
First, please try to locate the problem according to this FAQ topic: http://www.awesync.com/faq#idfile
 
If the reason of the problem is different, please provide us with the following information:
 
1) Awesync full log. You can paste the string %AppData%\AweSync\Log into your Windows explorer and attach all files from this folder to your reply message. We'll need the files to analyze your configuration.  Also, please provide:
2) your notes.ini file (with full path to this file, it is important);
3) your HKLM\software\lotus and HKCU\software\lotus Registry branches (they can be exported from your Registry).
4) If you use any shortcut to run your Notes, please let me know what it is (right-click on the shortcut and select Properties, then copy here the file paths).
Thanks,

#2

Hi ,
The FAQ didn't solve my problem. You will find attached the files asked in your post.
notes.ini full path is in C:\Users\J08157\AppData\Roaming\Notes\notes.ini
 
regards,

#3

Hello,
Did you find the solution ?
If you didn't find the attached files , please let me know .
 
regards.
 

#4

Please try the steps below:
1. In the Registry branch
HKEY_CLASSES_ROOT\HKCU\Software\Lotus\Notes\7.0
change the value as follow:
NotesIniPath=C:\Users\J08157\AppData\Roaming\Notes\notes.ini
2. Temporary remove the following strings from your notes.ini:
EXTMGR_ADDINS=zmAuto, C:\Users\J08157\AppData\Roaming\Notes\WORKSP~1\DskMgrHook.dll
DskMgrExePath=C:\Users\J08157\AppData\Roaming\Notes\WORKSP~1\DskMgr.exe
$DskMgrFirstRun=1
DskMgrHookActive=1
3. Run the program
C:\program files\notes\regsvr32 nlsxbe.dll
as described here: http://www.awesync.com/faq#com
4. Then reboot your computer and try to sync without starting any program.
If the problem remains, send to us Awesync full log one more time.

 

#5

Sorry , It didn't work.
You will find bellow the logs.
 
Regards.

#6

Could you please send to us the information below?
1) HKLM\software\lotus and HKCU\software\lotus branches;
2) shortcut you use to run Notes (we asked you to send it before);
3) two screenshots:
- in your Notes client select File menu/Preferences/User Preferences, Local database folder field.
- in your Notes client select File menu/Security/User Security, ID File field.
 
Thanks,

#7

We will find attached the file.zip with HKLM\software\lotus and HKCU\software\lotus branches, shortcut you use to run Notes and the 2 screenshots.

#8

Please now follow the steps below:

1. Open the file located in C:\Users\J08157\AppData\Roaming\Notes\notes.ini

and change the string

KeyFilename=C:\Notes\mail.id

to

KeyFilename=C:\Users\J08157\AppData\Roaming\Notes\aredon.id

2. Then please reboot your computer and try to sync without running any program except Awesync.

If the problem remains, please send to us the latest Awesync log file, screenshot of your shortcut (so that we can see paths to files it contains), HKLM\software\lotus and HKCU\software\lotus branches of Registry.

#9

Sorry Angela
 
The problem remains. You will find attached the files....

#10

Well, so here are the next steps to investigate the problem.
1. The shortcut you provided is for Awesync. Could you please provide the shortcut for your Notes client? Right-click on it and select Properties/Shortcut tab/Target.
2. In order to enable Awesync to use the right ID, open your notes.ini file and replace the string
KeyFilename=C:\Notes\mail.id
with
KeyFilename=C:\Users\J08157\AppData\Roaming\Notes\aredon.id
3. What option is selected in Lotus Notes ID settings in Awesync - Use current ID file or Use specified ID file?
 
Thanks,

#11

Hello Angela
I already changed my notes.ini file in my last try. ( changing KeyFilename=C:\Notes\mail.id by KeyFilename=C:\Users\J08157\AppData\Roaming\Notes\aredon.id) .
In my last try, I selected my "use current ID File" and 5 minutes laster , I selected   Use specified ID file with C:\Users\J08157\AppData\Roaming\Notes\aredon.id.  The same result , can not open id file!!

You will find attached my notes shortcut. Hope it can help you ...
I hate vista .... ;-) AweSync was working on windows XP! :-o
Regards.

#12

Hi
Did you find the work around ? 
Regards
Arnaud

#13

Hi Arnaud,
 
I will discuss your case with our development team one more time - seems that something went wrong at one of the steps we recommended. I let you know the results tomorrow.
 
Thanks,

#15

Hi Arnaud,
 
We checked your logs and information one more time, everything should work fine, but it doesn't. The problem may be in your Lotus Notes installation. Is it possible for your to reinstall your Notes client? It should be done using installation package, not just by files copying.
 
Please let me know.
 
 

#16

Status:more info» closed

Closed (no response for more than 2 weeks).
 
You can make this issue active any time if you still need assistance.
 

#19

Version:4.6.0» 4.11.0
Status:closed» active

Hello
I've got the same issue here, Awesync complains it cannot open the notes.ini file even when I choose the right file on my network drive.
I tried editing the reg file (defining Lotus as multi-user), but there was no key in HKCU for the Notes ini path.  I tried adding this by myself, rebooted, no change.
I'm including all the requested info in a zipped file.
By the way, i might have to ask you change my license.  I've registered this in an other division, and where i'm working now, my Lotus username has changed.
 
Regards

#20

 I am having the same problem
Attached you will find the log file
 

#21

 Hi all,
 
1) to  Matoridi 
I'll send you a hotfix by e-mail in several minutes.
2) to  apisani 
The problem is that Awesync cannot find the way to a server database.
2011-12-06 18:44:08,156 [4] WARN  - Can't get information about bad database: Database open failed (%1)
2011-12-06 18:44:08,171 [4] ERROR - Can't process: Can't open Lotus Notes database, make sure defined server name and database path are correct. Server: CN=Mail21/O=Epson, Path: mail\apisani.nsf
 
Please check if the server name Mail21/Epson and database path mail\apisani.nsf are correct. 
The reason may be in incorrect/incomplete data in Connections documents (you can find them in File/Locations/Manage Locations, then switch to Connections view). You have several Connections documents for the above server:
 
2011-12-06 18:43:58,250 [4] DEBUG - Found document Form: remote, Server: CN=MAIL21/O=EPSON, Port: , IP: , For user: *, For Location: Online
2011-12-06 18:43:58,281 [4] DEBUG - Found document Form: local, Server: CN=MAIL21/O=EPSON, Port: TCPIP, IP: mail21.ea.epson.net, For user: *, For Location: Online
 
As you can see the first document doesn't contain port and IP address. Please try to delete the first Connection document. 
If the problem remains, another possible reason may be in different Data folders used by .COM and Notes client. Please provide us with the following data, so that we can check your configuration and fix the problem: 
1) your notes.ini file located in C:\Program Files\IBM\Lotus\Notes\notes.ini
2) your HKLM\software\lotus and HKCU\software\lotus registry branches (they can be exported from your Registry).
3) If you use any shortcut to run your Notes, please let me know what paths it contains. 
4)The path specified in the field Local application folder in File menu/Preferences/User Preferences/ in your Notes client.
 
 
 Thanks,
 
 

#22

Hello
Thank you for your quick answer.
The 2 reg fixes partially solved the problem.  I am now able to sync toward google, but probably not toward Lotus.  Attached is the error log I get.
 
Thank you
 
MG
 

#23

Status:active» more info

 Hi MG,
 
Your Notes database got corrupted, and to fix it, please run the following commands on the server (I removed this info as requested).
 
 
Thanks,
 
 
 
 
 
 

#24

 
 
 
 
 
 
 
 
 

#25

 
 
 
 
 

#26

 
 
 
 
 

#27

How can I do that if I'm not the server admin?

(sorry about the extra and empty replys, had a problem with the browser...)

#28

Please remove my account and server information from this public forum

#29

Please remove my account and server information from this public forum

#30

 Hi,
 
As I can see, you removed the information from the forum. Just in case, if you consider some information confidential, you can write to our support directly: support@awesync.com

#31

Hello Angela

In My case, I did not request my info to be removed. Can you send me again the commands to run on the server?

Also, if you coyld tell me how to run those commands (I am not the server admin), it would be helpful...

Regards

#32

Again, I need the commands the commands you posted (then removed) for correcting my server mailbox database... And any input as to how to do that if I'M not the Lotus admin would be appreciated. you can email me instead for your answer.

#33

 I sent them by e-mail, please let me know if you received them.
 
Thanks,

#34

Closed (no response for more than 2 weeks).  
 
You can make this issue active any time if you still need assistance.

#35

Status:more info» closed